Resolved
Job matches performance has returned to normal. We apologize for the inconvenience.
Monitoring
We have implemented a fix and are monitoring
Investigating
We're experiencing degraded performance in job matches due to an issue with an upstream provider