·
Matches should be back to normal
Resolved
Monitoring
We've identified the issue and are monitoring the fix.
Investigating
We're experiencing degraded performance with our job matches and are investigating